Slowness and issues accessing accounts
Incident Report for Campaign Monitor
Resolved
Thankfully, the team managed to identify and resolve the issue quickly. If you still experience any issues at all, please just get in touch with support team via the public support form or via the in application support link.
Posted 10 months ago. Jan 16, 2018 - 08:14 PST
Investigating
We're aware that customers are experiencing slowness or issues accessing accounts. The team are investigating and we'll update here as soon as we have more information.
Posted 10 months ago. Jan 16, 2018 - 07:45 PST