Links in email campaigns not working for some customers
Incident Report for Campaign Monitor
Resolved
Normal service has now been restored. Once any affected draft campaigns are next saved, they will be automatically corrected for you.
Posted about 1 year ago. Nov 26, 2015 - 14:15 PST
Investigating
Some accounts may be experiencing issues when duplicating campaigns and with preview links.
Posted about 1 year ago. Nov 26, 2015 - 13:55 PST