Slowness and Issues Accessing Some Accounts
Incident Report for Campaign Monitor
Resolved
All accounts and access are now working as expected. Thank you for your patience!
Posted 8 months ago. Oct 18, 2018 - 09:35 PDT
Investigating
We're aware that customers are experiencing slowness or issues accessing accounts. The team are investigating and we'll update here as soon as we have more information.
Posted 8 months ago. Oct 18, 2018 - 08:35 PDT