Help Centers are temporarily inaccessible.
Incident Report for Campaign Monitor
Resolved
Campaign Monitor's Help Center and Support contact form are accessible.
Posted Jul 12, 2020 - 07:08 PDT
Update
The Help Center and Contact Form are still unavailable, but Campaign Monitor's Support team can now be contacted directly by email.
Posted Jul 11, 2020 - 15:01 PDT
Update
We are continuing to investigate this issue.
Posted Jul 11, 2020 - 12:07 PDT
Investigating
We are currently investigating this issue.
Posted Jul 11, 2020 - 08:38 PDT
This incident affected: Help site and contact form.