Intermittent issues with Forward to a Friend feature
Incident Report for Campaign Monitor
Resolved
The incident has now been resolved. Customers should no longer experience issues with the Forward to a Friend feature.
Posted May 27, 2020 - 16:17 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 27, 2020 - 15:46 PDT
Update
We are continuing to investigate the issue with the Forward to a Friend feature. We will provide an update when we have more details.
Posted May 27, 2020 - 12:48 PDT
Investigating
We have seen some customer reports of issues using the Forward to a Friend feature. We're investigating this further and will update this when we have more details.
Posted May 27, 2020 - 11:04 PDT