Customers experiencing some general delays and errors
Incident Report for Campaign Monitor
Resolved
After a period of monitoring, there have been no more further issues and we're confident everything is now resolved.
Posted Oct 11, 2019 - 10:26 PDT
Monitoring
The engineering team have put another fix in place and we'll continue to monitor the application.
Please note: If you're experiencing issues accessing your account, please try again as this may well have also impacted the ability to login to some accounts.
Posted Oct 11, 2019 - 08:00 PDT
Identified
Unfortunately, it looks like the problem has returned and the engineering team are looking into resolving the latest issues.
Posted Oct 11, 2019 - 05:23 PDT
This incident affected: Web Application (Campaign Reports (Opens, Clicks, WorldView), Campaign Creation & Previews, Email Builder, Lists).