Issues importing subscribers
Incident Report for Campaign Monitor
Resolved
The subscriber import issue has been resolved.
Posted 21 days ago. Aug 30, 2019 - 16:04 PDT
Update
We are currently investigating an issue with importing and adding subscribers.
Posted 21 days ago. Aug 30, 2019 - 15:45 PDT
Investigating
We are currently investigating an issue with importing and adding subscribers.
Posted 21 days ago. Aug 30, 2019 - 15:15 PDT
This incident affected: Web Application (Lists).