Some accounts are non-responsive
Incident Report for Campaign Monitor
Resolved
We were able to identify the issue and have put a fix in place. All accounts are now fully accessible. Thank you for your patience!
Posted 4 months ago. Jun 08, 2018 - 08:54 PDT
Investigating
Some of our customers may be experiencing issues accessing parts of the application and may also be seeing error messages. We are investigating and will update here once we know more. Thank you!
Posted 4 months ago. Jun 08, 2018 - 08:43 PDT