Login issues
Incident Report for Campaign Monitor
Resolved
This incident has been resolved.
Posted 4 days ago. Dec 05, 2018 - 19:47 PST
Monitoring
The ability to login has been restored. We will continue to monitor.
Posted 4 days ago. Dec 05, 2018 - 19:39 PST
Investigating
Some customers may be experiencing problems logging in. We're currently investigating.
Posted 4 days ago. Dec 05, 2018 - 19:29 PST
This incident affected: Web Application (Campaign Reports (Opens, Clicks, Insights & WorldView), Email Builder, Journeys, Lists, Templates, Campaign Creation & Previews).