Some customers are unable to pay for campaigns
Incident Report for Campaign Monitor
Resolved
Our payment processing company has resolved the issue and all campaign payments should go through successfully.
Posted 12 months ago. Dec 20, 2015 - 16:02 PST
Investigating
Some customers are receiving error messages when trying to pay for their campaigns, or add a new credit card to their account. Our payment processing company is working on a fix, but if you need to send urgently in the meantime, please contact our support team for help
Posted 12 months ago. Dec 20, 2015 - 14:38 PST