Payment Issues
Incident Report for Campaign Monitor
Resolved
Issues with adding card details to accounts has now been fully resolved.
Posted Oct 31, 2019 - 11:32 PDT
Monitoring
Issues with adding card details to accounts has now been resolved. We're currently monitoring the situation to ensure there is any continued problems.
Posted Oct 31, 2019 - 11:24 PDT
Identified
Our engineering team are working to resolve this as soon as possible. It's not currently possible to add new card details to an account to pay. However, customers that already have card details saved in their accounts will not be affected, you will continue to be able to send campaigns and emails.
Posted Oct 31, 2019 - 10:39 PDT
This incident affected: Web Application (Payment Gateway).