Payment gateway is not accepting Visa or Mastercard payments
Incident Report for Campaign Monitor
Resolved
It appears that the issue has been fully resolved with the third party and all payments are going through. Thanks for your patience, everyone!
Posted 3 months ago. May 25, 2018 - 19:26 PDT
Monitoring
The source of the interruption has been identified as a third-party provider. The services are returning and payments are showing as going through successfully. We will continue monitoring.
Posted 3 months ago. May 25, 2018 - 19:20 PDT
Identified
We have identified the source of the issue with accepting payments. We will continue to work on a fix. Thanks for your patience.
Posted 3 months ago. May 25, 2018 - 18:49 PDT
Investigating
Our payment gateway is currently rejecting payments from Visa and Mastercard. American Express is working fine, so please try an American Express card for USD payments if possible. We will continue to investigate.
Posted 3 months ago. May 25, 2018 - 18:10 PDT