Intermittent issues with the Customize Subscribe Process and Forward to a Friend feature
Incident Report for Campaign Monitor
Resolved
A fix has been implemented and both issues have now been resolved. Thanks for your patience.
Posted May 27, 2020 - 06:51 PDT
Identified
An issue has been identified and the team are working on a fix. Further updates will be posted soon.
Posted May 27, 2020 - 05:19 PDT
Investigating
We have seen some customers have experienced issues using the Forward to a friend feature and also Customize Subscribe Process within their accounts. We're investigating this further and will update this when we have more details.
Posted May 27, 2020 - 04:38 PDT
This incident affected: Web Application (Lists).