Segment Processing Issues
Incident Report for Campaign Monitor
Resolved
This incident has been resolved.
Posted Mar 23, 2020 - 16:02 PDT
Monitoring
A fix has been applied and most segments should now be processing as normal. We’re continuing to monitor and will resolve this incident once satisfied no more segments are affected.
Posted Mar 23, 2020 - 15:52 PDT
Investigating
We're aware that customers are experiencing slowness or issues creating segments. The team are investigating and we'll update here as soon as we have more information.
Posted Mar 23, 2020 - 13:26 PDT
This incident affected: Web Application (Segment Processing).