Issues sending test emails
Incident Report for Campaign Monitor
Resolved
This incident has been resolved.
Posted Jul 02, 2019 - 19:34 PDT
Monitoring
We've deployed a fix and test/preview emails can be sent again. We'll continue to monitor.
Posted Jul 02, 2019 - 19:29 PDT
Investigating
Some accounts man not be able to sent test/preview emails right now from the campaign snapshot page, or the email builder directly. We're currently working on it.
Posted Jul 02, 2019 - 19:26 PDT
This incident affected: Web Application (Campaign Creation & Previews).