Problems accessing draft campaigns
Incident Report for Campaign Monitor
Resolved
We can confirm the issue is now resolved. Customers should no longer have trouble accessing draft campaigns.
Posted Nov 27, 2019 - 19:34 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 27, 2019 - 19:28 PST
Identified
Some customers may be having trouble accessing draft campaigns. We're working on a fix for the issue right now.
Posted Nov 27, 2019 - 19:26 PST
This incident affected: Web Application (Campaign Creation & Previews).