Some customer payments are failing
Incident Report for Campaign Monitor
Resolved
There are no further problems with processing payments.
Posted Nov 06, 2020 - 13:41 PST
Investigating
Some of our customer payments are failing with the "Declined" message. We've taken our payment processing offline. This means customers that have a card saved should be able to continue sending and we'll process the payments once the payment processor is back online. We'll continue to investigate and will update with more details when they are available.
Posted Nov 06, 2020 - 10:44 PST
This incident affected: Web Application (Payment Gateway).