Issues saving campaigns and importing lists
Incident Report for Campaign Monitor
Resolved
The caching issue has cleared, and we’re not seeing any signs of continued errors. If you’ve experienced an issue saving an Email Builder campaign, refreshing the Editor then advancing to the Preview should help.
Posted Nov 10, 2019 - 17:16 PST
Identified
Some customers may experience problems saving campaigns, importing lists, and/or accessing templates due to some caching issues. If you’ve experienced this, try refreshing the page, then attempting the action again.
Posted Nov 10, 2019 - 16:56 PST
This incident affected: Web Application (Email Builder, Lists, Templates).