Problems accessing Campaign Monitor accounts
Incident Report for Campaign Monitor
Resolved
Our engineers have been able to resolve the issue and customers can now access accounts normally. During this time campaign links, reporting and ability to view images in campaigns may have been affected.
Posted 4 months ago. Mar 06, 2018 - 03:32 PST
Identified
The engineering team have identified the issue and are working to put a fix in place. Thanks for your continued patience.
Posted 4 months ago. Mar 06, 2018 - 02:59 PST
Investigating
Some customers are experiencing errors when attempting to access their accounts. Our engineering team have been informed and are working on resolving this as quickly as possible.
Posted 4 months ago. Mar 06, 2018 - 02:30 PST