Problem accessing accounts
Incident Report for Campaign Monitor
Resolved
This incident has been resolved.
Posted about 1 month ago. Mar 13, 2019 - 18:01 PDT
Monitoring
Accounts are accessible again. We'll continue to monitor.
Posted about 1 month ago. Mar 13, 2019 - 17:55 PDT
Investigating
Some customers may be experiencing issues logging in and accessing their account. We're currently investigating and will provide further updates.
Posted about 1 month ago. Mar 13, 2019 - 17:53 PDT
This incident affected: Web Application (Campaign Reports (Opens, Clicks, Insights & WorldView), Email Builder, Design & Spam Testing, Templates, Campaign Creation & Previews).