Problems accessing our main website at campaignmonitor.com
Incident Report for Campaign Monitor
Resolved
Our team have resolved any issues with access to campaignmonitor.com
Posted Oct 29, 2020 - 03:33 PDT
Monitoring
Our team have fixed the problems with access to campaignmonitor.com . Due to caching, customers may continue to see problems for a short time.
Posted Oct 29, 2020 - 03:19 PDT
Investigating
It's not possible to access our main campaignmonitor.com website at this time, our team are working on fixing this now. It's still possible to login to your account without any issues, if you don't know your account URL, you can use https://login.createsend.com/l to login. It's also possible to access our https://help.campaignmonitor.com support site without any problems.
Posted Oct 29, 2020 - 02:53 PDT
This incident affected: Marketing Site.