Issues with payments
Incident Report for Campaign Monitor
Resolved
There are no further problems adding card details to accounts.
Posted about 2 months ago. May 23, 2019 - 02:29 PDT
Monitoring
Issues with adding card details to accounts has now been resolved. We're currently monitoring the situation to ensure there is any continued problems,
Posted about 2 months ago. May 23, 2019 - 02:03 PDT
Update
Our engineering team are working to resolve this as soon as possible. It's not currently possible to add new card details to an account to pay. However, customers that already have card details saved in their accounts will not be effected, you will continue to be able to send campaigns and emails.
Posted about 2 months ago. May 23, 2019 - 00:11 PDT
Identified
Some customers may not be able to add or save a new credit card for payment. We are working on the issue.
Posted about 2 months ago. May 22, 2019 - 23:26 PDT
This incident affected: Web Application (Payment Gateway).