Account access issues
Incident Report for Campaign Monitor
Resolved
We haven't seen any further issues when accessing accounts. This incident is now resolved.
Posted 11 months ago. Nov 13, 2017 - 20:46 PST
Monitoring
Customers should now be able to access their accounts again. We'll continue to monitor the situation.
Posted 11 months ago. Nov 13, 2017 - 19:39 PST
Identified
Some customers may not be able to access their account. We're working on the issue right now and plan to have the problem rectified immediately.
Posted 11 months ago. Nov 13, 2017 - 19:36 PST