Slowness and Issues Accessing Some Accounts
Incident Report for Campaign Monitor
Resolved
All accounts and access are now working as expected. Thank you for your patience!
Posted Feb 28, 2020 - 10:31 PST
Identified
We're aware that customers are experiencing slowness or issues accessing accounts. The team are investigating and we'll update here as soon as we have more information.
Posted Feb 28, 2020 - 10:15 PST