Campaign Monitor accounts currently unavailable
Incident Report for Campaign Monitor
Resolved
You may now use your Campaign Monitor account as usual, all systems are performing well.
Posted about 1 year ago. Nov 16, 2015 - 18:08 PST
Monitoring
Campaign Monitor performing well and all is back to normal. We will continue to monitor the situation.
Posted about 1 year ago. Nov 16, 2015 - 17:01 PST
Investigating
We're investigating an interruption to your Campaign Monitor service - customers are not able to login, or pages in their account are not loading. We have our Operations and Engineering teams on the case right now and we'll update you here as soon as we know more.
Posted about 1 year ago. Nov 16, 2015 - 16:28 PST