Email sending issues
Incident Report for Campaign Monitor
Resolved
Sending has returned to normal and we're no longer seeing delays.
Posted 12 days ago. Nov 30, 2017 - 19:10 PST
Investigating
We’re experiencing delays sending emails. Campaigns may see slower processing times. We’re currently investigating.
Posted 12 days ago. Nov 30, 2017 - 18:04 PST