Campaign Reports are currently delayed
Incident Report for Campaign Monitor
Resolved
All reporting data has caught up and is running smoothly again. Apologies for any inconvenience. If you still see any issues, please feel free to reach out to the support team.
Posted Oct 02, 2019 - 03:06 PDT
Identified
Campaign reporting is currently running behind, but the engineering team are aware and are working on getting the data caught up.
Posted Oct 02, 2019 - 01:33 PDT
This incident affected: Web Application (Campaign Reports (Opens, Clicks, WorldView)).