Delays in campaign reporting
Incident Report for Campaign Monitor
Resolved
The issue with delays in campaign reporting has been resolved. There isn't any data loss and all reporting has caught up.
Posted about 1 month ago. Sep 19, 2019 - 09:17 PDT
Identified
We're currently experiencing delays with campaign reports within some customer accounts. There isn't any data loss and reporting should be caught up soon.
Posted about 1 month ago. Sep 19, 2019 - 08:45 PDT
This incident affected: Web Application (Campaign Reports (Opens, Clicks, WorldView)).