App may be down for some users
Incident Report for Campaign Monitor
Resolved
Our engineers have resolved the issue that was making the app inaccessible for some users.
Posted 2 months ago. Oct 06, 2017 - 12:44 PDT
Investigating
Our engineers are investigating an issue that is making the app unreachable for some users. We hope to have more details soon.
Posted 2 months ago. Oct 06, 2017 - 12:15 PDT