Log In Issues
Incident Report for Campaign Monitor
Resolved
This incident has been resolved.
Posted Oct 07, 2020 - 14:21 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 07, 2020 - 13:35 PDT
Update
We are continuing to investigate this issue.
Posted Oct 07, 2020 - 13:15 PDT
Investigating
Our team is investigating an issue that is affecting some users' ability to log in to the application.
Posted Oct 07, 2020 - 13:10 PDT
This incident affected: Web Application (Log In & Access).