Application Slowness
Incident Report for Campaign Monitor
Resolved
This incident has been resolved.
Posted Mar 24, 2020 - 13:52 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2020 - 11:33 PDT
Update
We are continuing to investigate this issue.
Posted Mar 24, 2020 - 11:00 PDT
Investigating
We are receiving reports from customers about general application slowness. We are aware of the reports and are looking into it. We will update as soon as we have more information.
Posted Mar 24, 2020 - 10:36 PDT