Delays with data showing up in campaign reports and lists
Incident Report for Campaign Monitor
Resolved
The data has caught up and all campaign reports should now be up-to-date. Thanks for your patience!
Posted 12 months ago. Dec 07, 2015 - 18:42 PST
Monitoring
Our engineers have identified the issue and reporting data is catching up. We continue to monitor the progress and will confirm when reports are up-to-date.
Posted 12 months ago. Dec 07, 2015 - 18:23 PST
Investigating
We're currently experiencing delays with data showing up in campaign reports. To confirm, no data has been lost. You may also see some delays in new signups showing up on lists.
Posted 12 months ago. Dec 07, 2015 - 18:02 PST