Problems loading Insights
Incident Report for Campaign Monitor
Resolved
The incident has now been resolved and Insights is loading again for all users.
Posted 9 days ago. Nov 04, 2018 - 21:16 PST
Investigating
We're currently investigating issues that are preventing Insights loading for some customers.
Posted 9 days ago. Nov 04, 2018 - 21:08 PST
This incident affected: Web Application (Campaign Reports (Opens, Clicks, Insights & WorldView)).