Intermittent issues with our Help Center
Incident Report for Campaign Monitor
Resolved
Our help center provider has resolved this incident. Our help sites are now working as expected for all users.
Posted Oct 26, 2019 - 07:33 PDT
Update
Access to our help site continues to be intermittent for some users. Our help center provider is continuing work on identifying a fix. We provide light support over the weekend, but will provide an update as soon as we become aware of a fix as we continue to monitor the partner's status page.
Posted Oct 25, 2019 - 21:42 PDT
Update
The provider used to host the Campaign Monitor help center and support contact form have been able to narrow down the impact of the intermittent latency issues. They are continuing to investigate and explore various resolution paths. We're continuing to monitor the partner's status page, and we'll update here as soon as there's an all clear!
Posted Oct 25, 2019 - 16:32 PDT
Update
The provider used to host the Campaign Monitor help center and support contact form are continuing to investigate the intermittent latency issues. We're continuing to monitor the partner's status page, and we'll update here as soon as there's an all clear!
Posted Oct 25, 2019 - 14:12 PDT
Update
The provider used to host the Campaign Monitor help center and support contact form are continuing to investigate the intermittent latency issues. We're continuing to monitor the partner's status page, and we'll update here as soon as there's an all clear!
Posted Oct 25, 2019 - 12:44 PDT
Update
The provider used to host the Campaign Monitor help center and support contact form are continuing to investigate the intermittent latency issues. We're continuing to monitor the partner's status page, and we'll update here as soon as there's an all clear!
Posted Oct 25, 2019 - 11:46 PDT
Update
The provider used to host the Campaign Monitor help center and support contact form are continuing to investigate the intermittent latency issues. We're continuing to monitor the partner's status page, and we'll update here as soon as there's an all clear!
Posted Oct 25, 2019 - 10:45 PDT
Update
The provider used to host the Campaign Monitor help center and support contact form are continuing to investigate the intermittent latency issues. We're continuing to monitor the partner's status page, and we'll update here as soon as there's an all clear!
Posted Oct 25, 2019 - 09:55 PDT
Identified
The provider used to host the Campaign Monitor help documentation and also our help contact form, are experiencing some intermittent latency when loading content, which may also be experienced on the user end. We're continuing to monitor the partner's status page, and we'll update here as soon as there's an all clear!
Posted Oct 25, 2019 - 08:40 PDT
This incident affected: Help site and contact form.