Delays in open and click processing. Campaign Reporting is currently delayed.
Incident Report for Campaign Monitor
Resolved
Email Open and Link Tracking is operational, and reporting is now up-to-date once again. Happy sending!
Posted about 1 year ago. Oct 01, 2015 - 06:41 PST
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 year ago. Oct 01, 2015 - 06:05 PST
Investigating
We are currently investigating this issue.
Posted about 1 year ago. Oct 01, 2015 - 05:57 PST