Email sending issues
Incident Report for Campaign Monitor
Resolved
We've now resolved sending delays on our end. Thanks for your patience!
Posted 11 days ago. Dec 01, 2017 - 14:47 PST
Update
Campaign reporting data regarding opens has now been restored to normal speeds. We are still seeing minor delays in email sending speeds, but hope to have that fully resolved shortly.
Posted 12 days ago. Dec 01, 2017 - 13:13 PST
Update
Our engineers are finishing up their work on a fix for the delay in data regarding opens and hope to deploy the fix in the next 10 minutes.
Posted 12 days ago. Dec 01, 2017 - 13:01 PST
Identified
A fix for the delay in data regarding opens is being developed and our engineers hope to have a fix applied in the next hour. We'll post updates as know more.
Posted 12 days ago. Dec 01, 2017 - 12:37 PST
Investigating
We’re experiencing delays sending emails. Campaigns may see slower processing times. We’re currently investigating. You may also see delays in data regarding opens showing up in your campaign reports. No data about email opens has been lost, it is just delayed in populating to reports.
Posted 12 days ago. Dec 01, 2017 - 11:31 PST