Login and account access issues
Incident Report for Campaign Monitor
Resolved
The issue with logins and account access has been resolved.
Posted Aug 31, 2020 - 13:55 PDT
Monitoring
A fix has been deployed for the login issue, and we are currently monitoring this component while we await further information.
Posted Aug 31, 2020 - 13:44 PDT
Update
We are continuing to investigate the reported issues with logging in and accessing accounts.
Posted Aug 31, 2020 - 13:21 PDT
Investigating
We are currently investigating reports of users being unable to log in and access accounts.
Posted Aug 31, 2020 - 12:54 PDT
This incident affected: Web Application (Log In & Access).