Problems sending campaigns
Incident Report for Campaign Monitor
Resolved
Campaigns have now been sent out and there are no outstanding problems sending campaigns.
Posted 25 days ago. Jul 29, 2019 - 04:23 PDT
Monitoring
The issue has been resolved, emails previously not sent are now sending and the backlog is clearing quickly.
Posted 25 days ago. Jul 29, 2019 - 04:10 PDT
Investigating
Our engineers are investigating reports of problems with campaign sending. Some campaigns are appearing as sent in customer accounts, but not all subscribers have been sent those campaigns. We're looking at the issues now and will have an update as soon as possible.
Posted 25 days ago. Jul 29, 2019 - 03:15 PDT
This incident affected: Email Sending (Email Campaigns & Journeys).