Delay in new subscribers appearing on lists
Incident Report for Campaign Monitor
Resolved
All data is now up-to-date and being processed at normal speeds.
Posted 16 days ago. Jun 08, 2017 - 11:25 PDT
Investigating
Some customers may notice a delay in new subscribers that are added via the API or a form appearing on lists. No data has been lost, it's simply delayed. We hope to be back to normal speeds soon.
Posted 16 days ago. Jun 08, 2017 - 09:10 PDT