Issue affecting sending of emails and degraded application performance
Incident Report for Campaign Monitor
Resolved
Campaigns and workflow emails were delayed, but have now sent. Sorry for the delays we caused.
Posted almost 2 years ago. Sep 24, 2015 - 18:46 PDT
Investigating
We are currently investigating this issue.
Posted almost 2 years ago. Sep 24, 2015 - 18:13 PDT