Issues importing subscribers
Incident Report for Campaign Monitor
Resolved
The issue is now resolved and subscribers can be imported again. Any imports that were attempted during the incident should have now completed.
Posted 2 months ago. Jul 08, 2019 - 17:19 PDT
Investigating
Some customers may not be able to import subscribers, either via a file, or manually. We're working on the issue and will provide more updates.
Posted 2 months ago. Jul 08, 2019 - 16:42 PDT
This incident affected: Web Application (Lists).