Problems sending campaigns
Incident Report for Campaign Monitor
Resolved
The issue has now been resolved and sending has returned to normal.
Posted 10 months ago. Oct 23, 2017 - 16:37 PDT
Monitoring
We've applied a fix and seeing reports that sending functionality is returning. We'll continue to monitor and will resolve this incident if no further issues arise.
Posted 10 months ago. Oct 23, 2017 - 16:28 PDT
Investigating
We're seeing reports of customers unable to send campaigns and are currently investigating. We will provide another update soon.
Posted 10 months ago. Oct 23, 2017 - 16:17 PDT