Login issues
Incident Report for Campaign Monitor
Resolved
All accounts and access are now working as expected.
Posted 2 months ago. Jan 14, 2019 - 14:46 PST
Identified
We’ve identified the cause of the login errors and are currently working on a fix. Thanks for your patience!
Posted 2 months ago. Jan 14, 2019 - 14:00 PST
Investigating
Some customers may be experiencing problems logging in. We're currently investigating.
Posted 2 months ago. Jan 14, 2019 - 13:41 PST
This incident affected: Web Application (Campaign Reports (Opens, Clicks, Insights & WorldView), Segment Processing, Email Builder, Journeys, Lists, Design & Spam Testing, Payment Gateway, Email Image Hosting, Hosted Subscribe Forms, Templates, Campaign Creation & Previews).