Delays in data showing up in campaign reports
Incident Report for Campaign Monitor
Resolved
All reporting data has now caught up and everything should be functioning normally.
Posted about 1 year ago. Nov 10, 2015 - 14:52 PST
Identified
We're experiencing temporary delays in reporting data (i.e. opens and clicks) showing up in campaign reports. No data has been lost, it is just a bit delayed. You may also see some delays in new signups showing up on lists.
Posted about 1 year ago. Nov 10, 2015 - 14:20 PST