Issues editing and previewing campaigns
Incident Report for Campaign Monitor
Resolved
This incident has been resolved.
Posted about 1 month ago. Mar 06, 2019 - 20:21 PST
Monitoring
Customers should be able to edit and preview campaigns again. We'll continue to monitor.
Posted about 1 month ago. Mar 06, 2019 - 20:15 PST
Investigating
Some customers may be having trouble attempting to edit or preview emails. We're aware of the issue and investigating right now. We will provide another update shortly.
Posted about 1 month ago. Mar 06, 2019 - 20:11 PST
This incident affected: Web Application (Campaign Creation & Previews).