Some email campaigns may be delayed in sending
Incident Report for Campaign Monitor
Resolved
Our engineers have now resolved this issue and all campaigns that were delayed should now have sent. Thanks for your patience!
Posted 5 months ago. Jan 09, 2018 - 13:37 PST
Investigating
We are investigating an issue that is causing delays with some campaigns. Our engineers hope to have this resolved quickly.
Posted 5 months ago. Jan 09, 2018 - 13:33 PST