Importing a campaign from a URL may not be working as expected
Incident Report for Campaign Monitor
Resolved
We're pleased to let you know the issue has been resolved and all campaign imports will work just fine. Thanks for your patience.
Posted 3 months ago. Oct 15, 2018 - 01:43 PDT
Identified
We're aware of and are currently looking into an issue which is affecting customers ability to import a campaign from a URL.
Posted 3 months ago. Oct 15, 2018 - 01:27 PDT