Campaign sending issues
Incident Report for Campaign Monitor
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 17, 2019 - 23:53 PDT
Monitoring
Affected campaigns are beginning to send again. We'll monitor and resolve this incident once the issue is completely resolved.
Posted 3 months ago. Mar 17, 2019 - 23:45 PDT
Identified
Some customers may see campaigns stuck sending. We've identified the issue and working on a fix right now. We'll provide another update shortly.
Posted 3 months ago. Mar 17, 2019 - 23:34 PDT
This incident affected: Email Sending (Email Campaigns & Journeys).