Intermittent errors in Campaign Monitor accounts
Incident Report for Campaign Monitor
All Campaign Monitor accounts are now operating at full speed without errors. We apologize for any interruptions and thank you for your patience.
Posted about 1 year ago. Sep 16, 2015 - 11:16 PDT
Some customers are seeing error pages when moving about in their Campaign Monitor account. Our engineering team are investigating the issue and we will update you as soon as possible. Refreshing the page a couple of times generally will bring the page back up.
Posted about 1 year ago. Sep 16, 2015 - 11:00 PDT