Some accounts non-responsive
Incident Report for Campaign Monitor
Resolved
All accounts and access are working as expected. Thank you so much for your patience!
Posted about 1 month ago. Jul 18, 2018 - 08:42 PDT
Investigating
Some customers may be experiencing issues accessing their accounts and parts of the application. Our developers are investigating the issue now. Thank you for your patience!
Posted about 1 month ago. Jul 18, 2018 - 08:26 PDT